NetSight
critical9.8

CVE-2024-40453

squirrelly Code Injection vulnerability

Impact

squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component `options.varName`. The issue was fixed in version 9.1.0.

Affected packages

EcosystemPackageAffectedFixed in
npmsquirrelly>= 9.0.0, < 9.1.09.1.0

Affected products

VendorProductAffected versions
SquirrellySquirrelly
Version 9.0.0

Weakness classification

References