medium6.8
CVE-2024-41675
CKAN has Cross-site Scripting vector in the Datatables view plugin
Impact
The [Datatables view plugin](https://docs.ckan.org/en/2.10/maintaining/data-viewer.html#datatables-view) did not properly escape record data coming from the DataStore, leading to a potential XSS vector. ### Impact Sites running CKAN >= 2.7.0 with the `datatables_view` plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. ### Patches This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0 ### Workarounds Prevent importing of tabular files to the DataStore via DataPusher, XLoader,etc, at least those published from untrusted sources.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | ckan | >= 2.7.0, < 2.10.5 | 2.10.5 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Okfn | Ckan | from 2.7.0 before 2.10.5 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/ckan/ckan/commit/9e89ce8220ab1445e0bd85a67994a51d9d3d2688
- https://github.com/ckan/ckan/commit/d7dfe8c427b1c63c75d788a609f3b7d7620a25a1
- https://github.com/ckan/ckan/security/advisories/GHSA-r3jc-vhf4-6v32
- https://github.com/advisories/GHSA-r3jc-vhf4-6v32
- https://nvd.nist.gov/vuln/detail/CVE-2024-41675