high8.8
CVE-2024-4181
RunGptLLM class in LlamaIndex has a command injection
Impact
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | llama-index | < 0.10.13 | 0.10.13 |
| pip | llama-index-llms-rungpt | < 0.1.3 | 0.1.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Llamaindex | Llamaindex | from 0.9.47 before 0.10.13 |