critical9.8
CVE-2024-43166
Apache DolphinScheduler Incorrect Default Permissions Vulnerability
Impact
Incorrect Default Permissions vulnerability in Apache DolphinScheduler. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.dolphinscheduler:dolphinscheduler | < 3.3.1 | 3.3.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Dolphinscheduler | before 3.2.2 |