critical9.8
CVE-2024-43202
Apache Dolphinscheduler Code Injection vulnerability
Impact
Exposure of Remote Code Execution in Apache Dolphinscheduler. This issue affects Apache DolphinScheduler: before 3.2.2. We recommend users to upgrade Apache DolphinScheduler to version 3.2.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.dolphinscheduler:dolphinscheduler-task-api | >= 3.1.0, < 3.2.2 | 3.2.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Dolphinscheduler | from 3.0.0 before 3.2.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apache/dolphinscheduler/pull/15758
- https://lists.apache.org/thread/nlmdp7q7l7o3l27778vxc5px24ncr5r5
- https://lists.apache.org/thread/qbhk9wqyxhrn4z7m4m343wqxpwg926nh
- https://www.cve.org/CVERecord?id=CVE-2023-49109
- http://www.openwall.com/lists/oss-security/2024/08/20/2
- https://github.com/advisories/GHSA-2fm6-mv57-p2qh
- https://nvd.nist.gov/vuln/detail/CVE-2024-43202
- https://github.com/apache/dolphinscheduler/commit/dc306bfa1d3ed72eb7b72b177e33a46042d2a9c3
- https://github.com/apache/dolphinscheduler/commit/c7789bf0499f5893810d93e144250544a528caa4