CVE-2024-43409
Ghost's improper authentication allows access to member information and actions
Impact
### Impact Improper authentication on some endpoints used for member actions would allow an attacker to perform member-only actions, and read member information. ### Vulnerable versions This security vulnerability is present in Ghost v4.46.0-v5.89.5. Ghost(Pro) customers are automatically updated to fixed versions ahead of disclosure. If you're a self-hoster, please follow our [update instructions](https://ghost.org/docs/update). ### Patches v5.89.5 contains a fix for this issue. ### Workarounds Disable site membership in Ghost settings. ### For more information If you have any questions or comments about this advisory: * Email us at [security@ghost.org](mailto:security@ghost.org)
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | ghost | >= 4.46.0, < 5.89.5 | 5.89.5 |
| npm | @tryghost/portal | >= 1.22.2, < 2.39.0 | 2.39.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ghost | Ghost | from 4.46.0 before 5.89.5 |