medium6.1
CVE-2024-44088
Apache Geode web-api is vulnerable to Cross-site Scripting
Impact
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover. This issue affects Apache Geode: all versions prior to 1.15.2. Users are recommended to upgrade to version 1.15.2, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.geode:geode-web-api | >= 1.1.0, < 1.15.2 | 1.15.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Geode | from 1.1.0 before 1.15.2 |