medium6.1
CVE-2024-45031
Apache Syncope: Stored XSS in Console and Enduser
Impact
When editing objects in the Syncope Console, incomplete HTML tags could be used to bypass HTML sanitization. This made it possible to inject stored XSS payloads which would trigger for other users during ordinary usage of the application. XSS payloads could also be injected in Syncope Enduser when editing “Personal Information” or “User Requests”: such payloads would trigger for administrators in Syncope Console, thus enabling session hijacking. Users are recommended to upgrade to version 3.0.9, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.syncope.client:syncope-client-console | >= 2.1.0, <= 2.1.14 | none recorded |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Syncope | from 2.1.0 before 3.0.9 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/fn567pfmo3s55ofkc42drz8b4kgbhp9m
- http://www.openwall.com/lists/oss-security/2024/10/24/2
- https://github.com/advisories/GHSA-jmrf-85g8-x8xv
- https://nvd.nist.gov/vuln/detail/CVE-2024-45031
- https://github.com/apache/syncope/commit/0c620a9eda2c0927875c129ebae66d2ea94f3e6a
- https://github.com/apache/syncope/commit/f80d3f6cfbd71acb03ece0f7601f660ee0be7e74
- https://syncope.apache.org/security#cve-2024-45031-apache-syncope-stored-xss-in-console-and-enduser