NetSight
high8.8

CVE-2024-45034

Apache Airflow vulnerable to Execution with Unnecessary Privileges

Impact

Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow< 2.10.12.10.1

Affected products

VendorProductAffected versions
ApacheAirflow
before 2.10.1

Weakness classification

References