critical9.8
CVE-2024-45216
Improper Authentication vulnerability in Apache Solr
Impact
Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.solr:solr | >= 5.3.0, < 8.11.4 | 8.11.4 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Solr | from 5.3.0 before 8.11.4 from 9.0.0 before 9.7.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://solr.apache.org/security.html#cve-2024-45216-apache-solr-authentication-bypass-possible-using-a-fake-url-path-ending
- http://www.openwall.com/lists/oss-security/2024/10/15/8
- https://github.com/advisories/GHSA-mjvf-4h88-6xm3
- https://nvd.nist.gov/vuln/detail/CVE-2024-45216
- https://issues.apache.org/jira/browse/SOLR-17417