medium5.3
CVE-2024-45384
druid-pac4j, Apache Druid extension, has Padding Oracle vulnerability
Impact
Padding Oracle vulnerability in Apache Druid extension, druid-pac4j. This could allow an attacker to manipulate a pac4j session cookie. This issue affects Apache Druid versions 0.18.0 through 30.0.0. Since the druid-pac4j extension is optional and disabled by default, Druid installations not using the druid-pac4j extension are not affected by this vulnerability. While we are not aware of a way to meaningfully exploit this flaw, we nevertheless recommend upgrading to version 30.0.1 or higher which fixes the issue and ensuring you have a strong druid.auth.pac4j.cookiePassphrase as a precaution.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.druid.extensions:druid-pac4j | >= 0.18.0, < 30.0.1 | 30.0.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Druid | from 0.18.0 before 30.0.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/gr94fnp574plb50lsp8jw4smvgv1lbz1
- http://www.openwall.com/lists/oss-security/2024/09/17/1
- https://github.com/advisories/GHSA-p72w-r6fv-6g5h
- https://nvd.nist.gov/vuln/detail/CVE-2024-45384
- https://github.com/apache/druid/commit/74cab7a76c99da457c3a883939cc0b03301b8771
- https://github.com/apache/druid/releases/tag/druid-30.0.1