NetSight
critical9.9

CVE-2024-45387

SQL injection in Apache Traffic Control

Impact

An SQL injection vulnerability in Traffic Ops in Apache Traffic Control <= 8.0.1, >= 8.0.0 allows a privileged user with role "admin", "federation", "operations", "portal", or "steering" to execute arbitrary SQL against the database by sending a specially-crafted PUT request. Users are recommended to upgrade to version Apache Traffic Control 8.0.2 if you run an affected version of Traffic Ops.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/apache/trafficcontrol/v8>= 8.0.0, < 8.0.28.0.2

Affected products

VendorProductAffected versions
ApacheTraffic Control
from 8.0.0 before 8.0.2

Weakness classification

References