NetSight
high7.5

CVE-2024-45401

Path traversal vulnerability in stripe-cli

Impact

### Impact A vulnerability exists in stripe-cli versions 1.11.1 and higher where a plugin package containing a manifest with a malformed plugin shortname installed using the --archive-url or --archive-path flags can overwrite arbitrary files. The update addresses the path traversal vulnerability by removing the ability to install plugins from an archive URL or path. There has been no evidence of exploitation of this vulnerability. ### Recommendation Upgrade to stripe-cli v1.21.3. ### Acknowledgements Thank you to [0xacb](https://hackerone.com/0xacb) and [bordiez](https://hackerone.com/bordiez) for reporting this vulnerability. ### For more information Email us at [security@stripe.com](mailto:security@stripe.com)

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/stripe/stripe-cli>= 1.11.1, < 1.21.31.21.3

Affected products

VendorProductAffected versions
StripeStripe Cli
from 1.11.1 before 1.21.3

Weakness classification

References