medium4.8
CVE-2024-45478
Apache Ranger has Stored Cross-site Scripting vulnerability in Edit Service Page
Impact
Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.ranger:ranger | < 2.5.0 | 2.5.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Ranger | from 2.4.0 before 2.5.0 |