NetSight
low2.6

CVE-2024-45719

Apache Answer: Predictable Authorization Token Using UUIDv1

Impact

Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: through 1.4.0. The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
gogithub.com/apache/incubator-answer< 1.4.11.4.1

Affected products

VendorProductAffected versions
ApacheAnswer
before 1.4.1

Weakness classification

References