NetSight
medium5.1

CVE-2024-45772

Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.

Impact

This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected. Users are recommended to upgrade to version 9.12.0, which fixes the issue. The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.lucene:lucene-replicator>= 4.4.0, < 9.12.09.12.0

Affected products

VendorProductAffected versions
ApacheLucene Replicator
from 4.4.0 before 9.12.0

Weakness classification

References