NetSight
medium5.4

CVE-2024-47050

Mautic vulnerable to XSS in contact/company tracking (no authentication)

Impact

## Summary Prior to this patch being applied, Mautic's tracking was vulnerable to Cross-Site Scripting through the Page URL variable. ## Patches Please update to 4.4.13 or 5.1.1 or later. ## Workarounds None ## References https://owasp.org/www-project-top-ten/2017/A7_2017-Cross-Site_Scripting_(XSS) https://owasp.org/www-project-web-security-testing-guide/latest/4-Web_Application_Security_Testing/07-Input_Validation_Testing/02-Testing_for_Stored_Cross_Site_Scripting If you have any questions or comments about this advisory: Email us at [security@mautic.org](mailto:security@mautic.org)

Affected packages

EcosystemPackageAffectedFixed in
composermautic/core>= 2.6.0, < 4.4.134.4.13
composermautic/core-lib>= 2.6.0, < 4.4.134.4.13

Affected products

VendorProductAffected versions
AcquiaMautic
from 2.6.0 before 4.4.13
from 5.0.0 before 5.1.1

Weakness classification

References