NetSight
medium4.8

CVE-2024-47058

Mautic vulnerable to Cross-site Scripting (XSS) - stored (edit form HTML field)

Impact

### Impact With access to edit a Mautic form, the attacker can add Cross-Site Scripting stored in the html filed. This could be used to steal sensitive information from the user's current session. ### Patches Upgrade to 4.4.13 or 5.1.1 or later. ### Workarounds None ### References - https://owasp.org/www-project-top-ten/2017/A7_2017-Cross-Site_Scripting_(XSS) - https://owasp.org/www-project-web-security-testing-guide/latest/4-Web_Application_Security_Testing/07-Input_Validation_Testing/02-Testing_for_Stored_Cross_Site_Scripting If you have any questions or comments about this advisory: Email us at [security@mautic.org](mailto:security@mautic.org)

Affected packages

EcosystemPackageAffectedFixed in
composermautic/core>= 5.0.0-alpha, < 5.1.15.1.1
composermautic/core-lib>= 5.0.0-alpha, < 5.1.15.1.1

Affected products

VendorProductAffected versions
AcquiaMautic
from 1.0.0 before 4.4.13
from 5.0.0 before 5.1.1

Weakness classification

References