critical9.8
CVE-2024-47552
Apache Seata Vulnerable to Deserialization of Untrusted Data
Impact
Deserialization of Untrusted Data vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): from 2.0.0 before 2.2.0. Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.seata:seata-config-core | >= 2.0.0, < 2.2.0 | 2.2.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Seata | from 2.0.0 before 2.2.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apache/incubator-seata/commit/20cd9625d23f99b71fefc83b8db96c14092a9950
- https://lists.apache.org/thread/652o82vzk9qrtgksk55cfgpbvdgtkch0
- http://www.openwall.com/lists/oss-security/2025/03/19/5
- https://github.com/advisories/GHSA-2r4x-667f-mpfh
- https://nvd.nist.gov/vuln/detail/CVE-2024-47552
- https://github.com/apache/incubator-seata/releases/tag/v2.2.0