high7.5
CVE-2024-51479
Next.js authorization bypass vulnerability
Impact
### Impact If a Next.js application is performing authorization in middleware based on pathname, it was possible for this authorization to be bypassed. ### Patches This issue was patched in Next.js `14.2.15` and later. If your Next.js application is hosted on Vercel, this vulnerability has been automatically mitigated, regardless of Next.js version. ### Workarounds There are no official workarounds for this vulnerability. #### Credits We'd like to thank [tyage](http://github.com/tyage) (GMO CyberSecurity by IERAE) for responsible disclosure of this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | next | >= 9.5.5, < 14.2.15 | 14.2.15 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Vercel | Next.Js | from 9.5.5 before 14.2.15 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/vercel/next.js/releases/tag/v14.2.15
- https://github.com/vercel/next.js/security/advisories/GHSA-7gfc-8cq8-jh5f
- https://github.com/advisories/GHSA-7gfc-8cq8-jh5f
- https://github.com/vercel/next.js/commit/1c8234eb20bc8afd396b89999a00f06b61d72d7b
- https://nvd.nist.gov/vuln/detail/CVE-2024-51479