medium6.5
CVE-2024-53299
Apache Wicket: An attacker can intentionally trigger a memory leak
Impact
The request handling in the core in Apache Wicket 7.0.0 on any platform allows an attacker to create a DOS via multiple requests to server resources. Users are recommended to upgrade to versions 9.19.0 or 10.3.0, which fixes this issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.wicket:wicket-core | >= 10.0.0, < 10.3.0 | 10.3.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Wicket | from 7.0.0 through 7.18.0 from 8.0.0 through 8.16.0 from 9.0.0 before 9.19.0 from 10.0.0 before 10.3.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/gyp2ht00c62827y0379lxh5dbx3hhho5
- http://www.openwall.com/lists/oss-security/2025/01/22/12
- https://github.com/advisories/GHSA-9cxr-76pm-j3wf
- https://nvd.nist.gov/vuln/detail/CVE-2024-53299
- https://wicket.apache.org/news/2025/01/31/wicket-8.17.0-released.html