NetSight
medium5.3

CVE-2024-53948

Apache Superset: Error verbosity exposes metadata in analytics databases

Impact

Generation of Error Message Containing analytics metadata Information in Apache Superset. This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-superset< 4.1.04.1.0

Affected products

VendorProductAffected versions
ApacheSuperset
before 4.1.0

Weakness classification

References