high6.5
CVE-2024-53949
Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled
Impact
Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API. issue affects Apache Superset: from 2.0.0 before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | apache-superset | >= 2.0.0, < 4.1.0 | 4.1.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Superset | from 2.0.0 before 4.1.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8d
- http://www.openwall.com/lists/oss-security/2024/12/09/4
- https://github.com/advisories/GHSA-35fc-9hrj-3585
- https://nvd.nist.gov/vuln/detail/CVE-2024-53949
- https://github.com/apache/superset/commit/7650c47e72f28559e91524f5d68d50c2060df4c7