medium4.3
CVE-2024-54016
Apache Seata Vulnerable to Data Amplification
Impact
Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Seata (incubating). This issue affects Apache Seata (incubating): through <=2.2.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.seata:seata-parent | >= 2.0.0, < 2.3.0 | 2.3.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Seata | from 2.0.0 before 2.3.0 |