NetSight
medium5.8

CVE-2024-5566

An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal …

Impact

An improper privilege management vulnerability allowed users to migrate private repositories without having appropriate scopes defined on the related Personal Access Token. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17.

Affected products

VendorProductAffected versions
GithubEnterprise Server
from 3.9.0 before 3.9.17
from 3.10.0 before 3.10.14
from 3.11.0 before 3.11.12
from 3.12.0 before 3.12.6
Version 3.13.0

Weakness classification

References