NetSight
critical9.8Known exploited

CVE-2024-56145

Craft CMS has potential RCE when PHP `register_argc_argv` config setting is enabled

Exploited in the wild

This vulnerability is on a Known Exploited Vulnerabilities catalogue, added 2025-06-02. Federal due date: 2025-06-23.

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Impact

### Impact You are affected if your php.ini configuration has `register_argc_argv` enabled. ### Patches Update to 3.9.14, 4.13.2, or 5.5.2. ### Workarounds If you can't upgrade yet, and `register_argc_argv` is enabled, you can disable it to mitigate the issue.

Affected packages

EcosystemPackageAffectedFixed in
composercraftcms/cms>= 5.0.0-RC1, < 5.5.25.5.2

Affected products

VendorProductAffected versions
CraftcmsCraft Cms
from 3.0.0 before 3.9.14
from 4.0.0 before 4.13.2
from 5.0.0 before 5.5.2

Weakness classification

References