NetSight
medium5.3

CVE-2024-5816

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a suspended GitHub App to retain access to the repository via …

Impact

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a suspended GitHub App to retain access to the repository via a scoped user access token. This was only exploitable in public repositories while private repositories were not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.9.17, 3.10.14, 3.11.12, 3.12.6, 3.13.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

VendorProductAffected versions
GithubEnterprise Server
from 3.9.0 before 3.9.17
from 3.10.0 before 3.10.14
from 3.11.0 before 3.11.12
from 3.12.0 before 3.12.6
Version 3.13.0

Weakness classification

References