NetSight
medium6.5

CVE-2024-5817

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects.

Impact

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects. This was only exploitable in internal repositories and required the attacker to have access to the corresponding project board. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

VendorProductAffected versions
GithubEnterprise Server
from 3.9.0 before 3.9.17
from 3.10.0 before 3.10.14
from 3.11.0 before 3.11.12
from 3.12.0 before 3.12.6
Version 3.13.0

Weakness classification

References