high7.5
CVE-2024-58375
OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, v…
Impact
OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, versions, and backend configurations. As a result, values marked as sensitive may be exposed through these configuration elements instead of producing an error. This is fixed in OpenTofu 1.8.3, which adds explicit errors to prevent the use of sensitive values in these contexts.
Affected products
| Product | Affected versions |
|---|---|
| OpenTofu Versions 1.8.0 | through 1.8.2 |
Versions were read from the advisory text. No structured product data has been published for this record yet.