medium6.4
CVE-2024-5945
The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to i…
Impact
The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Kubiq | Wp Svg Images | before 4.3 |
Weakness classification
References
- NVD record
- CVE.org record
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L111
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L313
- https://plugins.trac.wordpress.org/changeset/3105276/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3227378%40wp-svg-images&new=3227378%40wp-svg-images&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/389d96e9-1fad-49a6-89b6-8f7f108d8117?source=cve
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L111
- https://plugins.trac.wordpress.org/browser/wp-svg-images/trunk/wp-svg-images.php#L313
- https://plugins.trac.wordpress.org/changeset/3105276/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/389d96e9-1fad-49a6-89b6-8f7f108d8117?source=cve