high8.8
CVE-2024-6345
setuptools vulnerable to Command Injection via package URL
Impact
A vulnerability in the `package_index` module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages from URLs provided by users or retrieved from package index servers, are susceptible to code injection. If these functions are exposed to user-controlled inputs, such as package URLs, they can execute arbitrary commands on the system. The issue is fixed in version 70.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | setuptools | < 70.0.0 | 70.0.0 |
Affected products
| Product | Affected versions |
|---|---|
| Pypa/Setuptools | before 69.1.1 |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0
- https://huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5
- https://lists.debian.org/debian-lts-announce/2024/09/msg00018.html
- https://github.com/advisories/GHSA-cx63-2mw6-8hw5
- https://nvd.nist.gov/vuln/detail/CVE-2024-6345
- https://github.com/pypa/setuptools/pull/4332