high7.2
CVE-2024-9180
Vault Community Edition privilege escalation vulnerability
Impact
A privileged Vault operator with write permissions to the root namespace’s identity endpoint could escalate their privileges to Vault’s root policy. Fixed in Vault Community Edition 1.18.0 and Vault Enterprise 1.18.0, 1.17.7, 1.16.11, and 1.15.16
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/hashicorp/vault | < 1.18.0 | 1.18.0 |
| go | github.com/openbao/openbao | < 2.0.3 | 2.0.3 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Openbao | Openbao | before 2.0.3 |
| Hashicorp | Vault | from 1.7.7 through 1.17.7 from 1.7.7 before 1.18.0 from 1.15.0 before 1.15.16 from 1.16.0 before 1.16.11 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://discuss.hashicorp.com/t/hcsec-2024-21-vault-operators-in-root-namespace-may-elevate-their-privileges/70565
- https://github.com/advisories/GHSA-rr8j-7w34-xp5j
- https://nvd.nist.gov/vuln/detail/CVE-2024-9180
- https://pkg.go.dev/vuln/GO-2024-3191
- https://openbao.org/docs/release-notes/2-0-0/#203