NetSight
medium5.4

CVE-2024-9440

Slim Select has potential Cross-site Scripting issue

Impact

Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. This vulnerability is fixed in 2.9.2.

Affected packages

EcosystemPackageAffectedFixed in
npmslim-select>= 2.0.0, < 2.9.22.9.2

Affected products

VendorProductAffected versions
SlimselectjsSlim Select
before 2.9.2

Weakness classification

References