high7.5
CVE-2025-0182
A vulnerability in danswer-ai/danswer version 0.9.0 allows for denial of service through memory exhaustion.
Impact
A vulnerability in danswer-ai/danswer version 0.9.0 allows for denial of service through memory exhaustion. The issue arises from the use of a vulnerable version of the starlette package (<=0.49) via fastapi, which was patched in fastapi version 0.115.3. The vulnerability can be exploited by sending multiple requests to the /auth/saml/callback endpoint, leading to uncontrolled memory consumption and eventual denial of service.
Affected products
| Product | Affected versions |
|---|---|
| Starlette Package | through 0.49 |
Versions were read from the advisory text. No structured product data has been published for this record yet.