medium6.5
CVE-2025-11375
Consul event endpoint is vulnerable to denial of service
Impact
Consul and Consul Enterprise’s (“Consul”) event endpoint is vulnerable to denial of service (DoS) due to lack of maximum value on the Content Length header. This vulnerability, CVE-2025-11375, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| go | github.com/hashicorp/consul | < 1.22.0 | 1.22.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Hashicorp | Consul | before 1.18.12 before 1.22.0 from 1.19.0 before 1.20.8 from 1.21.0 before 1.21.6 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://discuss.hashicorp.com/t/hcsec-2025-28-consuls-event-endpoint-is-vulnerable-to-denial-of-service/76723
- https://github.com/advisories/GHSA-qh7p-pfq3-677h
- https://nvd.nist.gov/vuln/detail/CVE-2025-11375
- https://github.com/hashicorp/consul/pull/22836
- https://github.com/hashicorp/consul/commit/e794201d0c618333d81ad775270f7b32801178fb
- https://github.com/hashicorp/consul/releases/tag/v1.22.0
- https://pkg.go.dev/vuln/GO-2025-4082