medium4.3
CVE-2025-14691
Mayan EDMS is vulnerable to XSS through the /authentication/ file
Impact
A vulnerability was detected in Mayan EDMS up to 4.10.1. The affected element is an unknown function of the file /authentication/. The manipulation results in cross site scripting. The attack may be performed from remote. The exploit is now public and may be used. Upgrading to version 4.10.2 is sufficient to fix this issue. Users should upgrade the affected component. The vendor confirms that this is "[f]ixed in version 4.10.2". Furthermore, that "[b]ackports for older versions in process and will be out as soon as their respective CI pipelines complete."
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| pip | mayan-edms | >= 4.10.0, < 4.10.2 | 4.10.2 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Mayan-Edms | Mayan Edms | before 4.10.2 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html
- https://docs.mayan-edms.com/chapters/releases/4.10.2.html#security
- https://github.com/ionutluca888/Mayan-EDMS-XSS-POC
- https://vuldb.com/?ctiid.336409
- https://vuldb.com/?id.336409
- https://vuldb.com/?submit.711713
- https://github.com/advisories/GHSA-774q-r975-vqwp
- https://nvd.nist.gov/vuln/detail/CVE-2025-14691
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/45355cbb45a28f61f38f719112d0ff422e6dc688
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/94032fbe553e97b33e4e9b9e731b4fc45f9d9f91
- https://gitlab.com/mayan-edms/mayan-edms/-/commit/da9de60a9b84f11d5d2c7bbf118fe696b4f6357e
- https://github.com/pypa/advisory-database/tree/main/vulns/mayan-edms/PYSEC-2025-134.yaml