NetSight
medium5.5

CVE-2025-1474

MLflow has Weak Password Requirements

Impact

In mlflow/mlflow version 2.18, an admin is able to create a new user account without setting a password. This vulnerability could lead to security risks, as accounts without passwords may be susceptible to unauthorized access. Additionally, this issue violates best practices for secure user account management. The issue is fixed in version 2.19.0.

Affected packages

EcosystemPackageAffectedFixed in
pipmlflow< 2.19.02.19.0

Affected products

VendorProductAffected versions
LfprojectsMlflow
before 2.19.0

Weakness classification

References