low3.5
CVE-2025-15241
A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1.
Impact
A security vulnerability has been detected in CloudPanel Community Edition up to 2.5.1. The affected element is an unknown function of the file /admin/users of the component HTTP Header Handler. Such manipulation of the argument Referer leads to open redirect. It is possible to launch the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.5.2 is sufficient to fix this issue. Upgrading the affected component is recommended.
Affected products
| Product | Affected versions |
|---|---|
| CloudPanel Community Edition | before 2.5.1. |
Versions were read from the advisory text. No structured product data has been published for this record yet.
Weakness classification
References
- NVD record
- CVE.org record
- https://github.com/Stolichnayer/cloudpanel-open-redirect
- https://github.com/Stolichnayer/cloudpanel-open-redirect?tab=readme-ov-file#%EF%B8%8F-steps-to-reproduce
- https://github.com/cloudpanel-io/cloudpanel-ce/releases/tag/v2.5.2
- https://vuldb.com/?ctiid.338631
- https://vuldb.com/?id.338631
- https://vuldb.com/?submit.725543