NetSight
medium6.1

CVE-2025-15599

DOMPurify contains a Cross-site Scripting vulnerability

Impact

DOMPurify 3.1.3 through 3.2.6 and 2.5.3 through 2.5.8 contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting missing textarea rawtext element validation in the SAFE_FOR_XML regex. Attackers can include closing rawtext tags like </textarea> in attribute values to break out of rawtext contexts and execute JavaScript when sanitized output is placed inside rawtext elements. The 3.x branch was fixed in 3.2.7; the 2.x branch was never patched.

Affected packages

EcosystemPackageAffectedFixed in
npmdompurify>= 3.1.3, < 3.2.73.2.7

Affected products

VendorProductAffected versions
Cure53Dompurify
from 2.5.3 through 2.5.8
from 3.1.3 before 3.2.7

Weakness classification

References