high7.5
CVE-2025-1756
mongosh vulnerable to local privilege escalation
Impact
mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| npm | mongosh | < 2.3.0 | 2.3.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Mongodb | Mongosh | before 2.3.0 |
| Redhat | Codeready Linux Builder Eus | Version 9.4 |
| Redhat | Codeready Linux Builder For Arm64 Eus | Version 9.4_aarch64 |
| Redhat | Codeready Linux Builder For Ibm Z Systems Eus | Version 9.4_s390x |
| Redhat | Codeready Linux Builder For Power Little Endian Eus | Version 9.4_ppc64le |
| Redhat | Enterprise Linux Update Services For Sap Solutions | Version 9.4 |
| Redhat | Enterprise Linux Eus | Version 9.4 |
| Redhat | Enterprise Linux For Arm 64 | Version 9.4_aarch64 |
| Redhat | Enterprise Linux For Arm 64 Eus | Version 9.4_aarch64 |
| Redhat | Enterprise Linux For Ibm Z Systems | Version 9.4_s390x |
| Redhat | Enterprise Linux For Ibm Z Systems Eus | Version 9.4_s390x |
| Redhat | Enterprise Linux For Power Little Endian Eus | Version 9.4_ppc64le |