medium6.3
CVE-2025-21617
Guzzle OAuth Subscriber has insufficient nonce entropy
Impact
### Impact Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used. ### Patches Upgrade to version 0.8.1 or higher. ### Workarounds No. ### References Issue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| composer | guzzlehttp/oauth-subscriber | < 0.8.1 | 0.8.1 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192
- https://github.com/guzzle/oauth-subscriber/commit/92b619b03bd21396e51c62e6bce83467d2ce8f53
- https://github.com/guzzle/oauth-subscriber/releases/tag/0.8.1
- https://github.com/guzzle/oauth-subscriber/security/advisories/GHSA-237r-r8m4-4q88
- https://github.com/advisories/GHSA-237r-r8m4-4q88
- https://nvd.nist.gov/vuln/detail/CVE-2025-21617
- https://github.com/FriendsOfPHP/security-advisories/blob/master/guzzlehttp/oauth-subscriber/CVE-2025-21617.yaml