NetSight
high8.8

CVE-2025-23015

Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions

Impact

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.cassandra:cassandra-all>= 5.0-alpha1, < 5.0.35.0.3

Affected products

VendorProductAffected versions
ApacheCassandra
from 3.0.0 before 3.0.31
from 3.1 before 3.11.18
from 4.0.0 before 4.0.16
from 4.1.0 before 4.1.8
from 5.0.0 before 5.0.3

Weakness classification

References