NetSight
high8.0Known exploited

CVE-2025-23209

Craft CMS has a potential RCE with a compromised security key

Exploited in the wild

This vulnerability is on a Known Exploited Vulnerabilities catalogue, added 2025-02-20. Federal due date: 2025-03-13.

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Impact

### Impact This is an RCE vulnerability that affects Craft 4 and 5 installs where your security key has already been compromised. https://craftcms.com/knowledge-base/securing-craft#keep-your-secrets-secret Anyone running an unpatched version of Craft with a compromised security key is affected. ### Patches This has been patched in Craft 5.5.8 and 4.13.8. ### Workarounds If you can't update to a patched version, then rotating your security key and ensuring its privacy will help to migitgate the issue. ### References https://github.com/craftcms/cms/commit/e59e22b30c9dd39e5e2c7fe02c147bcbd004e603

Affected packages

EcosystemPackageAffectedFixed in
composercraftcms/cms>= 5.0.0-RC1, < 5.5.55.5.8

Affected products

VendorProductAffected versions
CraftcmsCraft Cms
after 4.0.0 before 4.13.8
after 5.0.0 before 5.5.8
Versions 4.0.0, 5.0.0

Weakness classification

References