NetSight
high7.5

CVE-2025-24853

Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability via Header Link Rendering

Impact

A carefully crafted request when creating a header link using the wiki markup syntax, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Further research by the JSPWiki team showed that the markdown parser allowed this kind of attack too. Apache JSPWiki users should upgrade to 2.12.3 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.12.32.12.3
mavenorg.apache.jspwiki:jspwiki-markdown< 2.12.32.12.3

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.12.3

Weakness classification

References