NetSight
medium6.9

CVE-2025-24854

Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin

Impact

A carefully crafted request using the Image plugin could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.3 or later.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.jspwiki:jspwiki-main< 2.12.32.12.3

Affected products

VendorProductAffected versions
ApacheJspwiki
before 2.12.3

Weakness classification

References