NetSight
medium6.1

CVE-2025-25247

Apache Felix Webconsole: XSS in services console

Impact

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix Webconsole. This issue affects Apache Felix Webconsole 4.x up to 4.9.8 and 5.x up to 5.0.8. Users are recommended to upgrade to version 4.9.10 or 5.0.10 or higher, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
mavenorg.apache.felix:org.apache.felix.webconsole>= 4.0.0, < 4.9.104.9.10

Affected products

VendorProductAffected versions
ApacheFelix Webconsole
from 4.0.0 before 4.9.10
from 5.0.0 before 5.0.10

Weakness classification

References