NetSight
medium6.9

CVE-2025-25299

Cross-site scripting (XSS) in the CKEditor 5 real-time collaboration package

Impact

### Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 real-time collaboration package. This vulnerability can lead to unauthorized JavaScript code execution and affects user markers, which represent users' positions within the document. This vulnerability affects only installations with [Real-time collaborative editing](https://ckeditor.com/docs/ckeditor5/latest/features/collaboration/real-time-collaboration/real-time-collaboration.html) enabled. ### Patches The problem has been recognized and patched. The fix will be available in version 44.2.1 (and above). ### For more information Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.

Affected packages

EcosystemPackageAffectedFixed in
npm@ckeditor/ckeditor5-real-time-collaboration>= 41.3.0, <= 44.2.044.2.1
npmckeditor5-premium-features>= 42.0.0, < 44.2.044.2.1

Weakness classification

References