high8.1
CVE-2025-26866
Apache HugeGraph-Server: RAFT and deserialization vulnerability
Impact
A remote code execution vulnerability exists where a malicious Raft node can exploit insecure Hessian deserialization within the PD store. The fix enforces IP-based authentication to restrict cluster membership and implements a strict class whitelist to harden the Hessian serialization process against object injection attacks. Users are recommended to upgrade to version 1.7.0, which fixes the issue.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| maven | org.apache.hugegraph:hg-pd-core | < 1.7.0 | 1.7.0 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Apache | Hugegraph | from 1.0.0 before 1.7.0 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/apache/incubator-hugegraph/pull/2735
- https://lists.apache.org/thread/ko8jkwbjbb99m45pg4sgo5xsm8gx9nsq
- http://www.openwall.com/lists/oss-security/2025/12/09/1
- https://github.com/advisories/GHSA-q37j-3367-fwv7
- https://nvd.nist.gov/vuln/detail/CVE-2025-26866