NetSight
medium6.3

CVE-2025-27018

Apache Airflow MySQL Provider is Vulnerable to SQL Injection

Impact

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.

Affected packages

EcosystemPackageAffectedFixed in
pipapache-airflow-providers-mysql< 6.2.06.2.0

Affected products

VendorProductAffected versions
ApacheApache-Airflow-Providers-Mysql
before 6.2.0

Weakness classification

References