medium5.8
CVE-2025-27219
CGI has Denial of Service (DoS) potential in Cookie.parse
Impact
There is a possibility for DoS by in the cgi gem. This vulnerability has been assigned the CVE identifier CVE-2025-27219. We recommend upgrading the cgi gem. ## Details CGI::Cookie.parse took super-linear time to parse a cookie string in some cases. Feeding a maliciously crafted cookie string into the method could lead to a Denial of Service. Please update CGI gem to version 0.3.5.1, 0.3.7, 0.4.2 or later. ## Affected versions cgi gem versions <= 0.3.5, 0.3.6, 0.4.0 and 0.4.1. ## Credits Thanks to lio346 for discovering this issue. Also thanks to mame for fixing this vulnerability.
Affected packages
| Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|
| rubygems | cgi | < 0.3.5.1 | 0.3.5.1 |
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| Ruby-Lang | Cgi | before 0.3.5.1 from 0.4.0 before 0.4.2 Version 0.3.6 |
Weakness classification
References
- NVD record
- CVE.org record
- GitHub advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27219.yml
- https://hackerone.com/reports/2936778
- https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html
- https://github.com/advisories/GHSA-gh9q-2xrm-x6qv
- https://github.com/ruby/cgi/pull/52
- https://github.com/ruby/cgi/pull/53
- https://github.com/ruby/cgi/pull/54
- https://www.cve.org/CVERecord?id=CVE-2025-27219
- https://nvd.nist.gov/vuln/detail/CVE-2025-27219